Page 3 of 4

Re: [POLL] Do you like "then,do,end" or "{ }"?

Posted: Tue Aug 06, 2013 3:04 pm
by jjmafiae
what about use unrelated words instead of "end" and "{}" like:

Code: Select all

if a = b then
     draw()
cat

Re: [POLL] Do you like "then,do,end" or "{ }"?

Posted: Tue Aug 06, 2013 7:23 pm
by LuaMaster
{ }s are confusing, and just don't don't look neat. then,do,end is the best way to go in my opinion

Re: [POLL] Do you like "then,do,end" or "{ }"?

Posted: Thu Aug 08, 2013 4:04 am
by T-Bone
jjmafiae wrote:what about use unrelated words instead of "end" and "{}" like:

Code: Select all

if a = b then
     draw()
cat
I think you meant

Code: Select all

if a == b then
     draw()
cat
:neko:

Re: [POLL] Do you like "then,do,end" or "{ }"?

Posted: Thu Aug 08, 2013 4:07 am
by Helvecta
if then cat?

Re: [POLL] Do you like "then,do,end" or "{ }"?

Posted: Thu Aug 08, 2013 8:24 am
by jjmafiae
depends on the langue i referred to in basic its just If a = b then
but yes in lua its if a == b then

it was kinda a joke.

Re: [POLL] Do you like "then,do,end" or "{ }"?

Posted: Fri Aug 09, 2013 4:59 am
by XHH
jjmafiae wrote:

Code: Select all

if a = b then
     draw()
cat

Code: Select all

if(a.getValue().parseInt().toString().isEqual(b.getValue.parseInt().toString()){
      doNothingReally();
}
Just thought I should turn that into Java to make it more readable.

(random burn on Java)

Re: [POLL] Do you like "then,do,end" or "{ }"?

Posted: Wed Aug 14, 2013 3:23 pm
by SeducingOrange
XHH wrote:
jjmafiae wrote:

Code: Select all

if a = b then
     draw()
cat

Code: Select all

if(a.getValue().parseInt().toString().isEqual(b.getValue.parseInt().toString()){
      doNothingReally();
}
Just thought I should turn that into Java to make it more readable.

(random burn on Java)
What about C++?

Code: Select all

#include <iostream>

using namespace std;

int main(int argc, char *argv[]) {
    int a = 5;
    int b = 5;
    if (a == b) {
        cout << "Hello, World" << endl;
    }
    return 0;
}

Re: [POLL] Do you like "then,do,end" or "{ }"?

Posted: Thu Aug 15, 2013 1:27 am
by XHH
simple C++ if statements like that are great. But once you really get into C++.... omg...

Re: [POLL] Do you like "then,do,end" or "{ }"?

Posted: Thu Aug 15, 2013 9:02 am
by Eamonn
XHH wrote:But once you really get into C++.... omg...
I agree. I don't like C++, but I do like Java! Java's a great language.I like the fact that you can string stuff like this together:

Code: Select all

obj = new ClassThingy()
obj.isTrue = doThis().doThat().doOther().box2d().libgdx()
It makes code more readable IMO. I've been trying to setup LDT for LÖVE because I really like Eclipse. Any videos I find don't help or any docs don't help, so it's a real pain in the butt to do. But ctrl-spacebar to see all the options you have... WONDERFUL.

Re: [POLL] Do you like "then,do,end" or "{ }"?

Posted: Thu Aug 15, 2013 10:15 am
by Robin
Eamonn wrote:I like the fact that you can string stuff like this together:

Code: Select all

obj = new ClassThingy()
obj.isTrue = doThis().doThat().doOther().box2d().libgdx()
That's not really a property of Java, you can do that in any language. (Except maybe PHP.)